2013年1月17日木曜日

i386とx86_64の環境で競合が発生。i386のModuleを削除

conflict_i386_x86_64yum updateするときに下記Errorが発生。

Transaction Check Error:
  file /usr/share/man/man1/curl.1.gz from install of curl-7.21.7-5.el5.remi.2.x86_64 conflicts with file from package curl-7.15.5-15.el5.i386

i386とx86_64のモジュールで競合が発生しているみたい。

環境: CentOS 5.8 x64, nginx 1.2.6, php 5.4.10

i386系のLibraryを削除するとupdateできるようになった
# yum remove glibc.i686
# yum update

かなりの数のLibraryが削除されるので事前に別環境で確認した方がいい。

 

参考Site

 

< Related Posts >

コメントを投稿
Related Posts Plugin for WordPress, Blogger...

Blog Archives